Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2008 IC windshield washer pump no power!
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

wjbusguy
Active Member

United States
23 Posts

Posted - 08/29/2013 :  2:15:50 PM  Show Profile  Visit wjbusguy's Homepage  Reply with Quote
Hi all, messed with this for a few minutes yesterday. Pump doesnt run and I dont show any voltage to it when the button is pushed. wipers work fine. Havent found a separate fuse for the washer, should there be a separate one for it or would it get power from the wiper circuit? I have an ISIS account but I dont access it much and am not to smart about finding my way around it, would like to find a wiring diagram for that particular circuit but no such luck so far.
Thanks in advance,
Mike

Fastback
Top Member

906 Posts

Posted - 08/29/2013 :  2:23:40 PM  Show Profile  Reply with Quote
Washer pump should have power at all times, the button supplies the ground. Follow loom and look for pinched or broken wires, loom runs under radiator to steering gear area and then back along frame as I recall.

Why yes, the ORIGinal CHARGER is a Fastback
Go to Top of Page

Bus Tech II
Senior Member

95 Posts

Posted - 08/30/2013 :  04:36:08 AM  Show Profile  Visit Bus Tech II's Homepage  Reply with Quote
Yes, it should have power at all times. most common spot for breakage is near the steering gear box, check the connector for "green" corrosion
Go to Top of Page

wjbusguy
Active Member

United States
23 Posts

Posted - 09/03/2013 :  07:10:13 AM  Show Profile  Visit wjbusguy's Homepage  Reply with Quote
Hey thanks for the replys guys, will check it out

Mike
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.09 seconds. Snitz Forums 2000