Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 08 IC CE300 -Parking brake service light
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

QzSue
New Member

1 Posts

Posted - 08/12/2013 :  5:29:51 PM  Show Profile  Visit QzSue's Homepage  Reply with Quote
I have an 08 IC CE300, DT466 with hydraulic brakes. Bus is running fine no other issues except the Brake pressure light stays on for a few seconds with initial start up. Now the service parking brake light is coming on when I am releasing the parking brake, it doesn't come on all the time just occasionally. Any help / advice with what to look for would be appreciated.

Bus Tech II
Senior Member

95 Posts

Posted - 08/13/2013 :  5:02:18 PM  Show Profile  Visit Bus Tech II's Homepage  Reply with Quote
Brake pressure light at start up is normal but goes off after the HCU reaches adequate pressures, front and rear. Do you have access to TOOLBOX software? If you hold the park brake in too long the service (P) will come on. look at the SAHR canister on the drivers frame rail near the rear axle and see if the solenoid looks severely rusted. They have updated the part to a heavier duty solenoid. Also in the SAHR the travel switch becomes very corroded.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.09 seconds. Snitz Forums 2000