Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 MBE900 smoking/weak
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Winn10
Active Member

20 Posts

Posted - 06/13/2013 :  6:35:31 PM  Show Profile  Visit Winn10's Homepage  Reply with Quote
Hey guys, I have a 2006 TBB EGR mbe900 that smokes and is really weak when it gets warm. I found this forum trying to research the problem. i've checked a/f, cac and piping, turbo, cc pressure, compression (#3 cyl 10psi below spec), fuel pressure (idle pressure good, 2500 rpm 15 psi lower than spec). any ideas that I can check without buying parts, our budget is shut off til july 1st?

Bassman
Top Member

USA
505 Posts

Posted - 06/14/2013 :  03:42:07 AM  Show Profile  Reply with Quote
First - any fuel filter or screen in the system. Second, is it missing? if so, I have seen it where the injector lines were loosened and the piece that the injector line screws onto comes loose causing an internal fuel leak inside the head(it is sort of like a nozzle that delivers fuel through the head.) Also, we have had two that had bad engine computers and caused them to be real dogs. But....those didn't smoke. I would guess fuel filter first.
Go to Top of Page

Tb4020
Senior Member

United States
63 Posts

Posted - 06/14/2013 :  03:44:58 AM  Show Profile  Reply with Quote
Your EGR cooler could be bad We had one act similar to that the cooler was bad replaced it and the EGR valve $$$$$ ridiculosly expensive just for parts. 6 months later (last fall) it dropped a valve and ruined the motor 105,000 miles on it $16,000 to fix it, can't buy a new bus for that. GOOD LUCK!
Go to Top of Page

Winn10
Active Member

20 Posts

Posted - 06/14/2013 :  07:04:33 AM  Show Profile  Visit Winn10's Homepage  Reply with Quote
quote:
Originally posted by Bassman

First - any fuel filter or screen in the system. Second, is it missing? if so, I have seen it where the injector lines were loosened and the piece that the injector line screws onto comes loose causing an internal fuel leak inside the head(it is sort of like a nozzle that delivers fuel through the head.) Also, we have had two that had bad engine computers and caused them to be real dogs. But....those didn't smoke. I would guess fuel filter first.


I replaced the filters already, and it does have a very slight miss. The inj lines on each pump are new but not the tapered tube thru the head. I swapped the ECM with a known good and still does the same thing. Thanks for the reply.

Edited by - Winn10 on 06/14/2013 07:05:16 AM
Go to Top of Page

Winn10
Active Member

20 Posts

Posted - 06/14/2013 :  07:09:22 AM  Show Profile  Visit Winn10's Homepage  Reply with Quote
quote:
Originally posted by Tb4020

Your EGR cooler could be bad We had one act similar to that the cooler was bad replaced it and the EGR valve $$$$$ ridiculosly expensive just for parts. 6 months later (last fall) it dropped a valve and ruined the motor 105,000 miles on it $16,000 to fix it, can't buy a new bus for that. GOOD LUCK!


the egr cooler has been replaced but not the valve. this is the only major problem we've had with any of our mbe's, just water pumps and oil cooler leaks. appreciate the help
Go to Top of Page

Winn10
Active Member

20 Posts

Posted - 06/14/2013 :  2:57:13 PM  Show Profile  Visit Winn10's Homepage  Reply with Quote
I guess I should add that the smoke is blue, sorry.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.12 seconds. Snitz Forums 2000