Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2005 International 4300 - A/C n/w
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

robert21
Active Member

United States
10 Posts

Posted - 06/12/2010 :  09:09:07 AM  Show Profile  Visit robert21's Homepage  Reply with Quote
Hello fellow "enthusiasts",
we have this 2005 International 4300 with "check A/C" warning light lit on the dash. We checked system pressures, they were low, due to leaking thermistors; we replaced both thermistors and recharged the system, the light is still on, the system does not cool, _ no power to compressor clutch, thermistors or the high pressure switch. We do not have a scanner for this truck. Does anyone know how to turn off the "check a/c" light? do we need a scanner?
Thanks for your time.
Bob C

robert21
Active Member

United States
10 Posts

Posted - 06/12/2010 :  10:37:45 AM  Show Profile  Visit robert21's Homepage  Reply with Quote
We found that by disconnecting the battery for a while, making sure the capacitors were drained of residual current; then reconnecting battery- now it works like a champ!
Go to Top of Page

jwreaume
Active Member

43 Posts

Posted - 06/14/2010 :  08:43:38 AM  Show Profile  Reply with Quote
You can try the following to clear the codes from the Body Controller or ESC:

Key On
While the gauges are cycling, put on the left turn signal, and press and hold the Cruise ON and Cruise SET buttons for about 5 seconds.

This will clear the codes in the ESC/BC.

17 years in the truck & bus world, 10 years at an IH Dealer, ASE Certified Master Medium & Heavy Truck Technician and Advanced Level Diesel Engine Diagnostic Specialist, IH Diamond Certified 5 Times, Instructor of Apprentice Techs in Engines, Fuels, Electrical & Electronics.

Ask anything, I likely will have the answer, or at least a believable lie for ya...

120 Units, 5 Bays, 5 Techs, Living the dream baby...

Edited by - jwreaume on 06/14/2010 08:44:06 AM
Go to Top of Page

edwright
New Member

1 Posts

Posted - 06/10/2013 :  12:17:16 PM  Show Profile  Visit edwright's Homepage  Reply with Quote
I wanted to give you guys a great big thank you. I have a 2005 8600 . I found your page by Googling 2005 International 8600 a/c pressure switch. My truck was low on coolant. I recharged it but the air conditioner still did not work. I tried the reset procedure mentioned on this page and voila I had ice cold a/c again. THANKS!!!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.09 seconds. Snitz Forums 2000