School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 c2 turn signal problem
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/10/2020 :  08:10:13 AM  Show Profile  Reply with Quote
i have a 2016 c2 with cummins 6.7 hydro brakes allison 2000 series trans i am having a problem with turn signals the left turn the only light thats works it the one on the very back the big rectanglular one the two on the left side of body are out and the on the hood in the headlight bezel dont have a diagram to see what goes where so kinda lost any ideas

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/10/2020 :  09:02:47 AM  Show Profile  Reply with Quote
CHM plug C3 pin "n" is power out to headlight and fender mount turn signal the rear and side should be CHM plug C1 pin g
I've seen M2 trucks and they use the trailer plug for the lights at the rear but a bus should be C1 for rear lights
The harness has rubbed through under chassis , either where it goes over the frame, or right by the side of engine block(driver side) at the "p" clamp

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/10/2020 :  10:57:19 AM  Show Profile  Reply with Quote
kewl i will start there thanks
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/10/2020 :  11:14:43 AM  Show Profile  Reply with Quote
ok ihave no power coming out of those pins i unpluged and powered up and the lights turned on so its gotta be either the imput into the chm or before that do u no what pins are the input for left front turn for chm
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/10/2020 :  12:25:04 PM  Show Profile  Reply with Quote
i have been trying to to reactivate my dtna for a week now but are the wiring diagrams in there along with service link
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/11/2020 :  08:57:43 AM  Show Profile  Reply with Quote
on the plug at CHM plug C3 (plug side) do you have your Vbat on pin J
This power feeds alot but left turn is in the list
if no then hat power comes from the fender mount PDM fuse 17(output will be in blue plug pin C)
Data link is the input
and no the wire diagrams are not with service link
if you can power the lights up from the plug at the CHM and you have a GOOD 12v at the CHM plug sounds like a bad CHM

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/11/2020 :  09:51:06 AM  Show Profile  Reply with Quote
ok will check that power at chm plug 3 pin J
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/11/2020 :  10:05:12 AM  Show Profile  Reply with Quote
ok checked pin J at c3 and it has 12v and then my head exploded because i realized there are two chm right next to each other how do i no i am on right one i checked and both had 12v at what is to be pin j at c3
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/11/2020 :  10:22:23 AM  Show Profile  Reply with Quote
I would pick the CHM that you unplugged and got the turn signal to light up on
no message on the LCD display of dash either then data link is aok

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/11/2020 :  10:33:22 AM  Show Profile  Reply with Quote
so u leaning towards chm i have a sister i could swapp out to be sure
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/12/2020 :  11:40:41 AM  Show Profile  Reply with Quote
i swapped out the chm with sister bus and it didnt like it all kinds of wierd things happened but before i order the correct one for it where does the input signal the chm com from its wierd to me the rectangual turn signal on rear of bus works but nothing else
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/12/2020 :  12:54:23 PM  Show Profile  Reply with Quote
i put everything back together because i had to move bus and the left turn signals on hood and body flashed a few times but dim and the went out its gotta be a wire ????? where does chm get the imput from for turn signal
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/13/2020 :  03:39:24 AM  Show Profile  Reply with Quote
remember some CHM if replaced with newer ones had the j1587 wires cut from plug
digital input ( data link)
the rear light comes from another plug from the CHM
important fact with CHM and BHM if the plug has a Vbat input make sure that it can hold a load on the wire if it can't everything else in that plug will not work
out puts are virtually fused internally in these modules

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/13/2020 :  04:13:36 AM  Show Profile  Reply with Quote
ok i will double check my vbat for load but what or where does the chm get the signal to power up the turn signal i now have a diagram of the connectors and pin outs of the chm but nothing shows the signal comming in or does it all come thru the data line and i need service link to see if its getting a signal
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/13/2020 :  05:06:24 AM  Show Profile  Reply with Quote
ok i just realized the diagram i have is for a 2007 and i am workin on a 2014 so my output to the side and fender marks are on c3 what pin my diagram shows c4 so to be sure i unplugged the c4 connector on a sister bus and the left turns still worked i unplugged the c3 and they went out so what pins on the c3 go to the marks
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/13/2020 :  05:30:36 AM  Show Profile  Reply with Quote
ok i am thinkin my problem is on the two body lights because my hood and fender lights will flash for a split second then nothing where as the two body lights never come on so one are the two connected or are the hood and fender separate from the body and what color wire are the body turn signals offnthe chm
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/14/2020 :  08:21:10 AM  Show Profile  Reply with Quote
G06-68408-000 is the part number of the wiring diagram you need
CHM c3 pin N is power out to left turn located on hood(one wire from CHM and splits at or near the frame by rad. and one goes to signal in headlamp and the other wire goes to fender mount)
CHM C1 pin G is power out to rear left turn now for the side lamp
the C3 plug should have a jumper harness in it with all yellow wires I've these go bad
not sure if they splice that wire right at the CHM and send a wire up through that floor plug by drivers left foot if they do I've seen that floor plug go bad also

OEM trained in wiring and all engine platforms for 20 years

Edited by - Bluenozer on 02/14/2020 08:50:50 AM
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/14/2020 :  12:36:36 PM  Show Profile  Reply with Quote
thanks for that info will look into that on monday it has to be a short some where the rear small left side body light it goes up there the left rear corner of bus then runs accross the inter side covers i cut that out to see if it was shorted and still nothing i power the light end up and that rea light turned on but the side light close to the stop sign did not so i hate shorts uggg
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/18/2020 :  12:28:22 PM  Show Profile  Reply with Quote
do u no what pin that side mark is on the c3 with yellow jumper
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/19/2020 :  03:44:30 AM  Show Profile  Reply with Quote
pin "N" out of the CHM on plug C3 ( not sue what pin after the YELLOW jumper)
our C2 buses the rear side light is marker only no flash , only side that flashes is by stop sign never had an issue with the side marker but I would guess that the wire from C3 pin "N" is spliced and that wire goes up through the floor plug by driver's left foot
our rear side marker light just feeds off of the ID lamps up top

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/25/2020 :  05:39:36 AM  Show Profile  Reply with Quote
just had to change a exit window left rear(buzzer always on), it had wires going down by the frame(of window) and the wires where chaffed through back lower corner
could be an issue for your lights also

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/26/2020 :  05:56:26 AM  Show Profile  Reply with Quote
will definitly check because my hood lights blink for a second but my side mark never turns on has to be a short in there was it the rear windowor the one in middle
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/26/2020 :  06:16:09 AM  Show Profile  Reply with Quote
bingo i started takin the left fron e window and the turn signals work so its gotta be in there how u gett that window fram out do u have to take that metal fram that the plastic trim mounts to????
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/26/2020 :  08:08:31 AM  Show Profile  Reply with Quote
i popped it out just a thermo up front, 4 screws , pop the top out of the way
pulled frame out then unplugged wires for the e buzzer

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/26/2020 :  08:15:34 AM  Show Profile  Reply with Quote
omg i cant believe how they ran this wire for the side turn signal i wish i could put pictures on here the just laid the wires over a piece of metal and pinched them in with the window fram u got to be kidding me now i gotta take seats out open up the side panel to repair the wires unbelievable but thanks for the tip bluenozer
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/26/2020 :  08:19:09 AM  Show Profile  Reply with Quote
and they are all like that so far lol
so if you get a window buzzer issue you know where to look

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/26/2020 :  12:59:20 PM  Show Profile  Reply with Quote
the window wire was run good it was the left body turn signal that was smashed against the window and the metalbody
Go to Top of Page

Bluenozer
Advanced Member

Canada
329 Posts

Posted - 02/27/2020 :  02:25:18 AM  Show Profile  Reply with Quote
I realize that but when you get a window buzzer that stays on , make this the first check

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Thomasbus24
Administrator

USA
4458 Posts

Posted - 02/27/2020 :  02:29:52 AM  Show Profile  Reply with Quote
quote:
Originally posted by dsalinas1939

u got to be kidding me now i gotta take seats out open up the side panel to repair the wires unbelievable but thanks for the tip bluenozer



I do believe I'd at least attempt to fish a new wire before I'd tear a bus apart. Worst case scenario you spend an hour of your life cussing and throwing tools VS a day of your life doing the same pulling seats and panels.
Go to Top of Page

dsalinas1939
Top Member

USA
1014 Posts

Posted - 02/27/2020 :  09:40:01 AM  Show Profile  Reply with Quote
gotcha bluenozer. i tried everything to not open everything up but the wire was cut an fell in body an it turns it doesnt go straight down to light so i had no choice but to open it up it wasnt that bad really
Go to Top of Page

Thomasbus24
Administrator

USA
4458 Posts

Posted - 02/28/2020 :  04:25:28 AM  Show Profile  Reply with Quote
Bummer. Glad it wasn't too bad though.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2017 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.38 seconds. Snitz Forums 2000