School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2007 International CE bus "Range Inhibit Light"
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

frcusmc
New Member

United States
9 Posts

Posted - 02/04/2009 :  10:08:46 AM  Show Profile  Reply with Quote
Apparently there is an intermittent problem with this bus.

It has been towed to me twice stating range inhibit light came on and bus will not go into gear.

Everytime I get it to troubleshoot it no light comes on and no codes for engine are present.

There was a code for the transmission inactive that was for the solenoid E.

Replaced module valve, solenoid E and the wiring harness first go round. Its back with the same complaint.

Any body else experience this?

flyboy
Senior Member

USA
147 Posts

Posted - 02/04/2009 :  11:08:14 AM  Show Profile  Visit flyboy's Homepage  Reply with Quote
Yes we have had a couple drivers report the range inhibit light coming on and the bus won't go into gear. We found that the drivers were operating the bus with the high idle/engine speed/cruise control in the on position. The powertrain control module will not allow the trans to go into gear if the engine idle is above curb idle speed or if the high idle engine speed control switch is on and the park brake is not on.
Go to Top of Page

frcusmc
New Member

United States
9 Posts

Posted - 02/04/2009 :  11:40:22 AM  Show Profile  Reply with Quote
Thanks so much for the reply "Flyboy" not sure if it was related but I did find an interlock switch for the lift door sticking R&Red it, but was still unable to duplicate the range inhibited light coming on. I tried releasing parking brake and with foot off of service brake tried shifting and it wouldn't turn the light on either. No codes on engine, abs system or tranny.
Go to Top of Page

Harrison Fire
Senior Member

United States
175 Posts

Posted - 02/04/2009 :  1:03:36 PM  Show Profile  Reply with Quote
Did you test it out by selecting a gear with the fast idle on?

The "Range Inhibit" light will illuminate and the bus will not shift into gear.

At least it will on a 09 IC CE DT466.

Cancel the fast idle, put it in neutral and the light goes away.

HF




My Fleet? (6) 93/99 IH 3800 Thomas and Blue Bird, Hydraulic Brakes, Manual and Auto Trans, (10) 00/06 FS65 Thomas Air Brake and Auto Trans, (2) 06 C2 Thomas and (2) 09/10 IC CE 300, Plus 3 more from another District
Go to Top of Page

bbird66
Top Member

USA
881 Posts

Posted - 02/04/2009 :  1:45:53 PM  Show Profile  Reply with Quote
...uh..Harrison?.... What the hell is that a picture of?

Were gonna miss you "Brent"..Good luck in "Heidi land"

"I know you miss the Wainwrights Bobby, but they were weak and stupid people...and that's why we have wolves and other large predators" .. The Far Side

"On a two hour delay when will my child be picked up??"








Go to Top of Page

frcusmc
New Member

United States
9 Posts

Posted - 02/04/2009 :  2:34:27 PM  Show Profile  Reply with Quote
"Harrison", unfortuntley I did not test out that theory as I was running out of time for the day but ty for the input. I'm sure that will help me with further issues concerning such. Much appreciated to all who replied
Go to Top of Page

BBInt.10
Top Member

USA
1042 Posts

Posted - 02/04/2009 :  5:39:55 PM  Show Profile  Visit BBInt.10's Homepage  Send BBInt.10 an AOL message  Reply with Quote
Isn't it standard practice to put your foot on the brake before shifting into gear? When you put your foot on the brake it automatically kills the high idle so I don't see what the issue would be there. While the green light on your high idle button will remain on, the idle will kick down to normal. I have never had an issue driving around with my high idle light on. Actually on most cold mornings I purposely leave my high idle switch on during my runs so that I may bump up the idle on my layovers simply by tapping the "accel" button once. I drive an '05 with a lever type shifter. Are the buses that are having these problems equipped with lever type shifters or push button shifters? At my last job, most of our buses had push-button shifters and what a NIGHTMARE those things can be.

If all your problems are behind you... you must be a school bus driver.
Go to Top of Page

acap03
Senior Member

USA
53 Posts

Posted - 02/04/2009 :  8:14:32 PM  Show Profile  Reply with Quote
What type of brakes does this bus have? We have the same issues with many of our C2's. We had buses getting stuck in turnarounds, at schools, and in the bus lots steady for 3-4 weeks straight. Finally..all of the Bendix brake valves were replaced and we have been "Range Inhibit" free since. I know you said it was a CE..but figured I would give my input..since it sounds exactly the same as what we were experiencing.

Im not sure that high-idle will have anything to do with it..since the bus probably has a brake interlock system if it is an 07. Therefore, you would have to have you foot on the brake in order to put it in gear..

Also, I might as well throw this in there..we havent had any problems with our CE's and the "RI" lights..but I drove one for a while a couples months ago while my bus was OOS..and I drove with the high idle/engine speed/cruise control in the "on" position and never had any issues. Although, I always had the bus in gear before I release the brake..so take it as you will.
Go to Top of Page

jeepcjron
Advanced Member

USA
262 Posts

Posted - 02/08/2009 :  5:19:02 PM  Show Profile  Reply with Quote
the lift door will cause the light.is the e solnoid code still there? check for harness rubbing at the back left of the engine also. i have seen some 1939 can wires rub and when they get wet it takes the can down causing a inhibit

its like a slinky! useless but fun to watch.
Go to Top of Page

frcusmc
New Member

United States
9 Posts

Posted - 02/09/2009 :  06:50:26 AM  Show Profile  Reply with Quote
I never got a code when this has happened however I did replace a sticking lift door interlock switch and it happened again the bus is back will check for rubbing harness on back of engine and ty.
Go to Top of Page

Harrison Fire
Senior Member

United States
175 Posts

Posted - 02/09/2009 :  09:43:13 AM  Show Profile  Reply with Quote
quote:
Originally posted by bbird66

...uh..Harrison?.... What the hell is that a picture of?



A throwback from my "Tapin'" days of listening to Black Sabbath, whilst cruising aimlesly. It's an artist's rendition of the song "Fairies Wear Boots"! With captions. Part of my Signature rotation.
The result of my aimless cruising.
HF
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2017 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.08 seconds. Snitz Forums 2000