School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 DEF sensor failures temporary relief
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Thomasbus24
Administrator

USA
4515 Posts

Posted - 09/23/2021 :  09:49:21 AM  Show Profile  Reply with Quote
If you, like so many of us, are faced with buses or trucks that are sitting because they need QLS sensors....now hear this....

Navistar has released a bulletin (IK0700115) advising that the EPA and CARB has agreed to allow a temporary programming update that will allow buses and trucks to run with QLS faults until parts are available.

I see no reason why Blue Bird and Thomas won't be able to follow (if they haven't already). If you need a bus up and running again, contact your dealer for info.

Hope this helps someone!

671Fan
Active Member

40 Posts

Posted - 09/23/2021 :  10:11:39 AM  Show Profile  Visit 671Fan's Homepage  Reply with Quote
Cool we have one that failed on the first day of school over a month ago. 7 days out of warranty. I was not pleased. Thank you
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 09/23/2021 :  10:47:00 AM  Show Profile  Reply with Quote
Cummins released TSB210087 for this issue also

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Thomasbus24
Administrator

USA
4515 Posts

Posted - 09/23/2021 :  11:21:15 AM  Show Profile  Reply with Quote
Good deal! I assumed it ultimately came down to Cummins to make this happen, not the OEMs. Hopefully the eventual recall makes this all right again...the components certainly don't last as long as they should have.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 09/24/2021 :  02:24:18 AM  Show Profile  Reply with Quote
they have no parts on the shelf, on ebay they are selling for $5000 and up lol , this calibration will remove the codes and derates, or its a def delete until parts come . not sure how they will cope with this global shortage

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Thomasbus24
Administrator

USA
4515 Posts

Posted - 09/24/2021 :  03:04:02 AM  Show Profile  Reply with Quote
I feel for the owner-operators out there who's trucks are sitting, unusable over this nonsense.

I wonder if the manufacturers convinced the EPA of this, or if....oh....say....some career politician got stranded along the road in her/her tour bus on the campaign trail by a DEF head failure? Hey, I can dream.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 09/24/2021 :  03:10:29 AM  Show Profile  Reply with Quote
their campaign bus lol

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

g0ttadrift
Senior Member

USA
196 Posts

Posted - 09/24/2021 :  04:04:04 AM  Show Profile  Reply with Quote
I like the way you think Thomasbus! Thanks for this info guys. We have been running ours anyways, until it goes into derate. Some buses have derated and others have been running with the CEL on for months.
Go to Top of Page

671Fan
Active Member

40 Posts

Posted - 09/24/2021 :  12:11:45 PM  Show Profile  Visit 671Fan's Homepage  Reply with Quote
Well I just called out local IH dealer and our 2016 Cummaparts engine is not on the list. Bus 26 is still unusable. Lovely.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 09/28/2021 :  05:55:39 AM  Show Profile  Reply with Quote
Just had a 2017 IH with an ISB6.7 come in yesterday , followed all trouble shooting steps for the 3 codes
3868,4572 and 4677 powers, grounds and data link all in spec, needs the header harness(sending unit in DEF tank) no stock anywhere part# is 4163693C91 and this engine does not fall into the TSB or IKnow documents
just the beginning I would say

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Thomasbus24
Administrator

USA
4515 Posts

Posted - 09/28/2021 :  06:43:09 AM  Show Profile  Reply with Quote
I'm trying to sort through a mountain of info on this, but it does look like Cummins will only offer the calibration on 17+ emissions units, which makes absolutely no sense whatsoever...what about all the older ones that don't run?!? I'll update as I find out more.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 09/28/2021 :  07:16:21 AM  Show Profile  Reply with Quote
they will have to expand it to include these years , the have no choice

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 09/29/2021 :  08:25:48 AM  Show Profile  Reply with Quote
Just had two more 2016 IH busses fail, called Cummins eastern Canaada and was told since these are not in the TSB it would be up to our Ih dealer to deal with , so no idea , someone important has to be affected before they change it for the masses

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 09/29/2021 :  10:50:07 AM  Show Profile  Reply with Quote
hers a list of year/make and def header part#, numbers might change up at dealer
2014 C2 A04-28046-000
2015 IH 4163693C91
2016 IH 4163693C91
2019 BB 10019935
2020 BB 10049766
2021 IH 4097724C91
2022 IH 4097724C91
Freightliner shows stock for the 2014 , IH has no stock on any of their part numbers, Blue Bird did not contact for stock , but I imagine it is none
hope this helps

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

671Fan
Active Member

40 Posts

Posted - 09/30/2021 :  10:00:05 AM  Show Profile  Visit 671Fan's Homepage  Reply with Quote
I was talking with our Bird dealer a few weeks ago and he was saying 2-3 months out. IH had a part number change for our application two weeks ago and they still have no idea when it will be available.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 10/01/2021 :  09:35:17 AM  Show Profile  Reply with Quote
Lol working on this 2016 Ih , trouble shooting says to check water valve for heating the def tank, tank temp hit 96f and codes came active(2015 IH only hit 68f and a 2019 BB hit 68f) so I figured maybe the valve is not closing(was thinking faulty header was opening it ) part# 4178946C1 no stock anywhere , I let it cool down and got coolant hoses pinched off to see if it will throw those codes again
will update
def tank got to 76f , codes came active and coolant was at 179f ran for around 30 mins, wondering if this was the first time the header talked over the J1939 from engine start
So is the header bad and telling the coolant valve to flow( was open when pinchers were removed) or the valve itself is leaking
all my readings were taken with a infrared temp. gun
grateful this is Friday

OEM trained in wiring and all engine platforms for 20 years

Edited by - Bluenozer on 10/01/2021 10:04:38 AM
Go to Top of Page

Thomasbus24
Administrator

USA
4515 Posts

Posted - 10/01/2021 :  10:51:04 AM  Show Profile  Reply with Quote
My last three in-warranty failures it has been determined that the valve was faulty and it was replaced along with the head. Makes me wonder if the valve is the root cause and not the other way around? Cooking the sensor?
Go to Top of Page

671Fan
Active Member

40 Posts

Posted - 10/01/2021 :  1:39:58 PM  Show Profile  Visit 671Fan's Homepage  Reply with Quote
IH had a failure mode like that where the coolant lines were reversed putting the hot line closer to the electronics. My current failure is 4 at once, level sense failure, temp sense failure, reagent quality sense failure and monitoring system failure.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 10/03/2021 :  11:09:47 AM  Show Profile  Reply with Quote
Ok,found out another guy figured out that the coolant valve fails first def evaporate enter the header harness and cools and crystallizes and takes them out , he states the updated coolant valves are red at the connector , but he was replacing both as a pair before now

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Thomasbus24
Administrator

USA
4515 Posts

Posted - 10/04/2021 :  05:08:35 AM  Show Profile  Reply with Quote
Makes sense. All of my failures happened at the end of long routes on afternoons where the temps were in the 90s.
Go to Top of Page

671Fan
Active Member

40 Posts

Posted - 10/05/2021 :  3:43:27 PM  Show Profile  Visit 671Fan's Homepage  Reply with Quote
Well, our "new" def header arrived today after over a month of waiting. It is clearly a used part. Filthy on top, dirty harness and there are still some urea crystals on one of the plastic tubes. Filter and plastic ties look new. To put it mildly, I am less than impressed.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 10/06/2021 :  02:25:59 AM  Show Profile  Reply with Quote
I'm working on installing a ball valve in the coolant line between the valve and def tank to let the tank get to between 60 and 70F , so if you got ones getting hot but no codes yet we can trick it, can't block it off , the header waits about 40 minutes until the first communication happens it it will need to see a temp. increases in this time
will update if it works

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

671Fan
Active Member

40 Posts

Posted - 10/08/2021 :  10:03:11 AM  Show Profile  Visit 671Fan's Homepage  Reply with Quote
Well so far so good. Installed the header, tested the coolant valve and gave it a good test drive. No problems yet.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 10/12/2021 :  09:33:19 AM  Show Profile  Reply with Quote
I got a coolant valve in today(red connector) installed ran unit, no issues, test drove after 40 minutes on fast idle def temp. was 67F , soon as I hit the road the 3 codes came active. so the header is needed and the old valve had to be leaking as the def was getting over 90F , so one piece of the puzzle arrived
at least the header works 671fan
I should add the def line pressure did not build until I went to leave , went up the 132psi and stayed then the next thing the 3 codes came back

OEM trained in wiring and all engine platforms for 20 years

Edited by - Bluenozer on 10/12/2021 09:37:34 AM
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 10/19/2021 :  10:42:55 AM  Show Profile  Reply with Quote
My associate has a wrecker company and Kenworth from the US called him to say they will not be able to build his two new units that he ordered due to this chip shortage, I guess Perterbilt is now doing the same thing with trucks on order in North America

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Trailboss
Senior Member

United States
193 Posts

Posted - 10/20/2021 :  04:06:07 AM  Show Profile  Reply with Quote
Has any one gotten the software update yet? I have a bus at our dealers and they say they have to wait for the vin number to come up and they come out on Tuesdys and Thurdays.
Go to Top of Page

Trailboss
Senior Member

United States
193 Posts

Posted - 11/16/2021 :  04:33:26 AM  Show Profile  Reply with Quote
Has anyone been getting DEF sensors or had the software programing done? Stll waiting its been 2 months now.
Go to Top of Page

Bluenozer
Advanced Member

Canada
484 Posts

Posted - 11/16/2021 :  05:34:55 AM  Show Profile  Reply with Quote
I received a new header harness for the unit i was working on , it works no issues
the calibration is simple they block codes and deactivate the DEF system so its a 1/4 delete

OEM trained in wiring and all engine platforms for 20 years
Go to Top of Page

Thomasbus24
Administrator

USA
4515 Posts

Posted - 11/18/2021 :  03:56:26 AM  Show Profile  Reply with Quote
I have one bus running since the week the update came out, the gauge doesn't work, but that's the only thing we've noticed that is different about the operation of the bus.
Go to Top of Page

Trailboss
Senior Member

United States
193 Posts

Posted - 11/22/2021 :  12:26:04 PM  Show Profile  Reply with Quote
Got our bus back Friday from the dealer with the softwear programing. Ran fine coming back to our school and fine today on the bus routes. Everthing seems to be running fine no lose of power and def gauge is working.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2017 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.17 seconds. Snitz Forums 2000