Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2003 DT466
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

second.flood
Advanced Member

USA
336 Posts

Posted - 03/03/2014 :  10:11:51 AM  Show Profile  Reply with Quote
I have a DT466 that just started using several quarts of oil each day.
No smoke.
Turbo clean.
This engine has recently been serviced and has clean oil so I can't tell if the oil is going to the fuel tank.
110,000 miles
8,200 hours

Is my next step pulling the injectors?


Thanks

Oldiron
Active Member

15 Posts

Posted - 03/03/2014 :  10:21:04 AM  Show Profile  Visit Oldiron's Homepage  Reply with Quote
Yup, thats where I would go.
Go to Top of Page

sambrutay
Advanced Member

United States
231 Posts

Posted - 03/04/2014 :  04:48:43 AM  Show Profile  Reply with Quote
Pull some fuel from the fuel tank and see how dark it is. Or check the racore bowl. If its dark your on it. Injector O-ring.

Bruce
Go to Top of Page

second.flood
Advanced Member

USA
336 Posts

Posted - 03/07/2014 :  1:20:51 PM  Show Profile  Reply with Quote

Go to Top of Page

Oldiron
Active Member

15 Posts

Posted - 03/10/2014 :  06:12:28 AM  Show Profile  Visit Oldiron's Homepage  Reply with Quote
Winner! Winner! Chicken Dinner!!
Go to Top of Page

second.flood
Advanced Member

USA
336 Posts

Posted - 03/10/2014 :  06:42:46 AM  Show Profile  Reply with Quote
Thanks Oldiron,
New injectors arrive today. :)
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.11 seconds. Snitz Forums 2000