Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 6.2L sluggish
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

C.HARDY
Advanced Member

354 Posts

Posted - 11/29/2013 :  8:02:40 PM  Show Profile  Click to see C.HARDY's MSN Messenger address  Reply with Quote
It seems I keep getting sluggish engines this week. I now have a 93 GMC with a 6.2L. Starts right up and runs fine but is lacking power something bad. It seems the electric fuel pump that is mounted on the frame isnt running. Would this cause it to go lean? Any input is appreciated.

mastertech
Advanced Member

243 Posts

Posted - 12/12/2013 :  6:45:19 PM  Show Profile  Visit mastertech's Homepage  Reply with Quote
If the pulse pump on the frame quits Im surprised it would even run. You must not be in the salt belt if you have a 1993 .
Go to Top of Page

C.HARDY
Advanced Member

354 Posts

Posted - 12/14/2013 :  7:31:44 PM  Show Profile  Click to see C.HARDY's MSN Messenger address  Reply with Quote
ha ha no salt here in Va. It does run but lacks power awful. Im going to start on it this week I hope and see whats up.

"Hardybusman"
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.08 seconds. Snitz Forums 2000