Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2005 DT-466
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

second.flood
Advanced Member

USA
364 Posts

Posted - 10/31/2013 :  08:27:45 AM  Show Profile  Reply with Quote
2005 IC/CE DT-466

Code 422 inactive...cleared code then it came back.

Intermittent low power and smoke... mostly when cold.

Whenever I get the bus it runs fine and smooth. I have tried wiggling the harness for #2 while running. I have run all the tests through Master Diagnostics.

The harness at the valve cover is oil filled and leaking.

Time for injector? What else do you guys do while in there besides valve adjustment?






willism
Senior Member

United States
143 Posts

Posted - 10/31/2013 :  12:20:57 PM  Show Profile  Visit willism's Homepage  Reply with Quote
New valve cover gasket and a icp sensor we always do had alot of icps go out the last 2 yrs.
Go to Top of Page

Bus Tech II
Senior Member

108 Posts

Posted - 10/31/2013 :  12:33:44 PM  Show Profile  Visit Bus Tech II's Homepage  Reply with Quote
I agree! lots of intermittent power issues from ICP sensors.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.14 seconds. Snitz Forums 2000