Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 Bus won't shift
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Been Deleted
Active Member

USA
13 Posts

Posted - 10/09/2013 :  1:34:55 PM  Show Profile  Reply with Quote
I have a 2007 rear engine blue bird with a ISC 8.3, and a GEN 4 3000 series transmission. The bus will randomly not want to shift into gear after being started. After the driver cycles the starter a few times it will start and run fine. When it happens it says (RANGE INHIBIT) on the dash. There are no codes on the transmission or the engine. It doesn't seem to have a pattern, just stops working for a while and then works. Any ideas?

AW
Active Member

42 Posts

Posted - 10/09/2013 :  6:08:16 PM  Show Profile  Reply with Quote
Make sure the fast idle switch is off
Go to Top of Page

Oldiron
Active Member

20 Posts

Posted - 10/10/2013 :  03:18:27 AM  Show Profile  Visit Oldiron's Homepage  Reply with Quote
Also check with driver to make sure service brake is being applied.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.12 seconds. Snitz Forums 2000