Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 ECM Fuse blows in battery box
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Trailboss
Senior Member

United States
149 Posts

Posted - 09/18/2013 :  08:42:46 AM  Show Profile  Reply with Quote
2008 IC CE Maxforce 7. The ECM fuse blows that is in the battery box. Unhooked the ECM relay under the hood turned the key and it does not blow the fuse hook it back up and blows again. The wires go down to the loom going into the ECM do think the ECM has a short in it or has anyone have any other ideas.
Thanks

Farmridge
Senior Member

51 Posts

Posted - 09/18/2013 :  11:46:19 AM  Show Profile  Reply with Quote
Check all the wiring from the ECM, the relay, and the battery box. Replace the ECM relay. If all those fail, then you may have a shorted ECM, very doubtful.

If you can't handle the answer, don't ask the question
Go to Top of Page

Farmridge
Senior Member

51 Posts

Posted - 09/18/2013 :  12:04:16 PM  Show Profile  Reply with Quote
Check all the wiring from the ECM, the relay, and the battery box. Replace the ECM relay. If all those fail, then you may have a shorted ECM, very doubtful.

If you can't handle the answer, don't ask the question
Go to Top of Page

05ICCE
Senior Member

USA
68 Posts

Posted - 09/18/2013 :  4:56:25 PM  Show Profile  Visit 05ICCE's Homepage  Reply with Quote
there was a recall/service campaign a few years ago that replaced that harness. i do not know if it applies to the 2008, check it out.

Mr. Scott, "because he drives a COOL BUS"
Go to Top of Page

HH59
New Member

3 Posts

Posted - 09/30/2013 :  10:34:34 AM  Show Profile  Visit HH59's Homepage  Reply with Quote
JUST HAD TO REPLACE ECM SAME PROBLEM ALSO BUS WOULD NOT SHUT OFF
Go to Top of Page

BJ Henderson
Advanced Member

USA
228 Posts

Posted - 09/30/2013 :  12:41:56 PM  Show Profile  Send BJ Henderson an AOL message  Reply with Quote
See what the codes are, if any.

CMTT,CMAT,CMBT
Go to Top of Page

Trailboss
Senior Member

United States
149 Posts

Posted - 10/04/2013 :  03:25:07 AM  Show Profile  Reply with Quote
Checked all of the wiring from the fuse to the ECM could not find any shorts. Removed and replaced ECM relay it still shorted out. Sent the bus to our local Dealer. They found the fuel pump was shorting out and was the problem. They removed and replaced the fuel pump under warranty and all is good.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.14 seconds. Snitz Forums 2000