Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2001 AmTran FE ABS light
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Thomasbus24
Administrator

USA
3369 Posts

Posted - 06/23/2013 :  3:32:47 PM  Show Profile  Reply with Quote
Hoping someone can point me in the direction of an easy fix.

I bought this 01 AmTran for a big bus spare, it needs some TLC but is a decent bus overall. Air brakes by the way.

I was chasing down a current draw issue, pulling one chassis breaker at a time. After the ABS breaker was removed and installed, the darn ABS light is on. It wasn't before, but it did work during the self-test on startup.

The modulators still do the click-click-click test at key-on.

Anything yall can think of that removing and reinstalling the breaker could have done, or is it just a coincidence?

By the way...current draw wasn't the ABS system, it had to do with the 8-ways.

IBTMech
Top Member

USA
973 Posts

Posted - 06/23/2013 :  5:47:04 PM  Show Profile  Visit IBTMech's Homepage  Reply with Quote
Bendix or Wabco? It might just need a reset.

If it doesn't fit, FORCE it.
If it breaks, well, it needed replacing anyway.
Pullin' wrenches for 45 years.

Edited by - IBTMech on 06/23/2013 6:03:45 PM
Go to Top of Page

Wolf0r
Top Member

USA
2179 Posts

Posted - 06/25/2013 :  11:35:46 AM  Show Profile  Reply with Quote
You drive it yet? Resetting the box you have to drive it over 3mph and the lamp should go out.

“The good thing about science is that it's true whether or not you believe in it.”
Neil deGrasse Tyson
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.16 seconds. Snitz Forums 2000