Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 non running
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

dieselderek
New Member

3 Posts

Posted - 05/07/2013 :  12:50:18 AM  Show Profile  Visit dieselderek's Homepage  Reply with Quote
hi all
we got a international bus not sure of age but old , we are in uk and was imported recently , on way to scotland cut out. i was called and checked fuel from fuel tank to filter and was lfting ok from tank, got it running after bleed but cut out after 4 miles and was running rough , now will not start ???????, ps it is a v8 diesel

eddo
Senior Member

USA
91 Posts

Posted - 05/07/2013 :  08:45:55 AM  Show Profile  Reply with Quote
fuel filters? I live in the US desert where our diesel is pretty dirty, but that sounds just like what happens when our filters get clogged- especially if this is a 7.3L v8.
Go to Top of Page

IBTMech
Top Member

USA
973 Posts

Posted - 05/07/2013 :  4:05:02 PM  Show Profile  Visit IBTMech's Homepage  Reply with Quote
We need more vehicle information. Diagnostics on the net is not so simple.

If it doesn't fit, FORCE it.
If it breaks, well, it needed replacing anyway.
Pullin' wrenches for 45 years.
Go to Top of Page

dieselderek
New Member

3 Posts

Posted - 05/08/2013 :  1:37:48 PM  Show Profile  Visit dieselderek's Homepage  Reply with Quote
got it running after un plugging several plugs and re plugging in
when i touched engine wiring loom it stalled and would not re start, i removed complete wiring harness from engine and checked each wire , i found a plug 2pin in the bottom of the vee at the front along side a aluminium pump below power steer pump wires shorting there , re fitted harness now runs fine and will be earning money as a mobile food bar in scotland uk , does any one know what the plug was for thank you all for assistance
Go to Top of Page

dieselderek
New Member

3 Posts

Posted - 05/10/2013 :  1:26:49 PM  Show Profile  Visit dieselderek's Homepage  Reply with Quote
first class information from you all , thank you , bus got to new home ok , i will post photo of it in its new job when i get a photo sent , thanks again derek
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.11 seconds. Snitz Forums 2000