Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 hard start
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

ricky g
Active Member

30 Posts

Posted - 03/28/2013 :  04:33:14 AM  Show Profile  Visit ricky g's Homepage  Reply with Quote
Good morning , have a 2005 6.0 litre ford van will only start with a shot of ether first thing in the morning , no engine light on , replaced glow plug relay , has had low battery problems in the past , any chance FICM is faulty due to previous low battery problems , Thanks

Fastback
Top Member

938 Posts

Posted - 03/28/2013 :  04:54:29 AM  Show Profile  Reply with Quote
Are the glow plugs energizing or not? Cranking speed is important, whats the condition of the starter and the battery cable terminal connecting to it? The road salts get to ours.

Why yes, the ORIGinal CHARGER is a Fastback
Go to Top of Page

Wolf0r
Top Member

USA
2177 Posts

Posted - 03/28/2013 :  1:10:24 PM  Show Profile  Reply with Quote
Check the battery under the van on the frame and where the ground cable bolts up. I've had to put star washers on a few.

“The good thing about science is that it's true whether or not you believe in it.”
Neil deGrasse Tyson
Go to Top of Page

ricky g
Active Member

30 Posts

Posted - 04/12/2013 :  07:34:11 AM  Show Profile  Visit ricky g's Homepage  Reply with Quote
Thank you very much , side batterys were ok but connections were terrible , replaced cable from side batteries [2] , and cleaned all grounds , starts perfect now , Thanks again .
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.53 seconds. Snitz Forums 2000