Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 Just Stopped Running
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

mrfrigabear
New Member

5 Posts

Posted - 02/26/2013 :  04:49:55 AM  Show Profile  Visit mrfrigabear's Homepage  Reply with Quote
I have a 2007 IC RE 200 that just stopped running. Won't start, good crank. Code says IDM bad. Replaced lower IDM and still won't start.

Bus Tech II
Senior Member

97 Posts

Posted - 02/26/2013 :  09:15:12 AM  Show Profile  Visit Bus Tech II's Homepage  Reply with Quote
I would venture to say clean power fuse wiring and/or connector in the battery box.
Go to Top of Page

slippert
Advanced Member

USA
373 Posts

Posted - 02/26/2013 :  12:20:49 PM  Show Profile  Reply with Quote
Second that^^^^, factory fuse holder is a common problem on that vintage IC-CE buses. At least it was here.
Go to Top of Page

meanmechanic01
Active Member

17 Posts

Posted - 03/02/2013 :  3:23:54 PM  Show Profile  Visit meanmechanic01's Homepage  Reply with Quote
Ive had a problem with the IDM relay connector, if you look at the metal connectors sometimes theres one thats a bit melted and expanded. Also the power and ground wires rub thru when you follow them past the battery box towards the starter.
Go to Top of Page

CanUC2
New Member

4 Posts

Posted - 03/04/2013 :  08:09:28 AM  Show Profile  Visit CanUC2's Homepage  Reply with Quote
quote:
Originally posted by meanmechanic01

Ive had a problem with the IDM relay connector, if you look at the metal connectors sometimes theres one thats a bit melted and expanded. Also the power and ground wires rub thru when you follow them past the battery box towards the starter.



Ditto!!!! It's Normally the Relay...
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.12 seconds. Snitz Forums 2000