Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2011 C2 6.7 Coolant Code Problem
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

1983ChevroletWayne
Senior Member

Canada
165 Posts

Posted - 01/25/2013 :  08:06:50 AM  Show Profile  Reply with Quote
Hey guys,

We have a 6.7 C2 (2011) showing a low coolant code & then the low coolant code clears and a high coolant code replaces it. The boys at the shop can't seem to clear it. (code 195 then 197)

The check engine light stays on and will not clear. Coolant levels are accurate. A new probe was put into the bus and the problem still exists.

This morning the guys got me to take the bus for a good run at highway speed, and when I had left the shop the check engine light went out for about 10 seconds and then came back on (and stayed on). I had the temperature to about 190 on the gauge. The pickup speed seems to be lacking, but when you finally do get the bus going it will reach good speeds on the highway.

When they ran the laptop on the bus they saw were the code had gone from low level coolant code (then the 10 second gap) to a high level coolant code.

Any thoughts or suggestions?

Edited by - 1983ChevroletWayne on 01/25/2013 09:12:26 AM

1983ChevroletWayne
Senior Member

Canada
165 Posts

Posted - 01/30/2013 :  08:09:55 AM  Show Profile  Reply with Quote
Found the issue guys. It was the relay for the coolant temperature switch. The new relay was a 12 volt instead of the proper 5 volt relay.

They look identical except for the part number.

Formerly "83ChevroletWayne"



Pic courtesy of: "schoolbusdriver.org"
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.17 seconds. Snitz Forums 2000