Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 2008 Bluebird eng quit
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

eshover
Active Member

24 Posts

Posted - 09/04/2012 :  06:00:36 AM  Show Profile  Visit eshover's Homepage  Reply with Quote
A neighboring school has a 2008 BB All American AFE bus that quit here Friday night. The error codes on the speedo are: Eng Comm Fail & Battery Error. The engine turns over well but will not fire.
It has a Cummins 6.7L eng.
I checked batteries, wires, fuses but found nothing wrong.
Has anyone run into these codes or had this problem?
Thanks,
ED

eshover
Active Member

24 Posts

Posted - 09/04/2012 :  07:10:01 AM  Show Profile  Visit eshover's Homepage  Reply with Quote
Where would that be located?Inside frame rail?
ED
Go to Top of Page

eshover
Active Member

24 Posts

Posted - 09/04/2012 :  07:23:06 AM  Show Profile  Visit eshover's Homepage  Reply with Quote
Went out to the bus and I don't see any shut off.
ED
Go to Top of Page

Wolf0r
Top Member

USA
2177 Posts

Posted - 09/05/2012 :  09:24:59 AM  Show Profile  Reply with Quote
I read above you checked the fuses already but they may not be getting power. Pull the black multiplex cover off and check EVERY fuse block to see if you have any blown fuses. Pay particular attention to the ECM power and ECM ignition fuses. The relays right above those power up the circuit. If that's all good seek help unless you have a scanner to see if the boxes are communicating. I have had two ECUs fail this year from heat.

“The good thing about science is that it's true whether or not you believe in it.”
Neil deGrasse Tyson

Edited by - Wolf0r on 09/05/2012 09:28:20 AM
Go to Top of Page

eshover
Active Member

24 Posts

Posted - 09/21/2012 :  1:22:32 PM  Show Profile  Visit eshover's Homepage  Reply with Quote
This bus went to the Cummins dealer and they found the ECM had failed. New ECM problem solved.
Ed
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.14 seconds. Snitz Forums 2000