Read about the Great Fleets Across America
Subscribe

School Bus Fleet Magazine Forums
School Bus Fleet Magazine Forums
Home | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Professional Garage
 Enter Forum: Professional Garage
 dt466e t444e cam sensor compatability
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

mrwaibel
Senior Member

USA
93 Posts

Posted - 10/02/2010 :  12:05:39 PM  Show Profile  Send mrwaibel an AOL message  Reply with Quote
I have a cam sensor on my bus starting to get bad. The last couple mornings I have started it and the check engine light comes on for 10 seconds or so then it goes out, then it sometimes sputters when I come to a stop. Its a 2004 Blue Bird International with the DT466 engine in it. I was told that the DT466E will run with every other sensor bad except the cam sensor and the oil pressure sensor. One very experienced mechanic I talked to said that the cam sensor for a t444e will work in a dt466 and their much cheaper as well. I was told the t444e sensor has the exact same dimensions the only difference is that it will advance the timing 2-3 degrees, I was wondering if anyone on here had ever tried the swap. The dt466 sensor is $129.00 the t444e sensor is only $17.00 the they both look exactly the same.

IBTMech
Top Member

USA
973 Posts

Posted - 10/02/2010 :  3:55:51 PM  Show Profile  Visit IBTMech's Homepage  Reply with Quote
Personally, I would buy the sensor that Navistar says is the correct cam sensor for your VIN.

The replacements are a different design, including a shim kit and instructions.

You may end up buying the cheaper (just to get rid of them) old design.

I've changed a lot of them, some for the second time (old design). The new design seems do be doing a lot better(so far).

If it doesn't fit, FORCE it.
If it breaks, well, it needed replacing anyway.
Pullin' wrenches for 45 years.
Go to Top of Page

Trailboss
Senior Member

United States
148 Posts

Posted - 10/04/2010 :  03:38:04 AM  Show Profile  Reply with Quote
I would personely go with OEM. I have run lots of 466's and 444e's. I have very seldom changed the cam sensor twice on the same engine. How many miles does your engine have on it now.That probably will be about the same mileage you should get out of a new one. Unless you have some kind of problem that is causeing them to fail.
Go to Top of Page

Big John
Active Member

USA
15 Posts

Posted - 10/04/2010 :  11:44:57 AM  Show Profile  Reply with Quote
I have used 444 sensors in 466's many times...some fore 75000miles and never had any trouble. A 466 sensor will not work in a 444 because its turned a little in the holder and wont bolt in without grinding the hold down tab.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
 


School Bus Fleet Magazine Forums © 2013 School Bus Fleet Magazine Go To Top Of Page
This page was generated in 0.11 seconds. Snitz Forums 2000